ECLIPSE Support Notes

This page contains information about key topics for our ECLIPSE plug-ins. We are also revising our ECLIPSE support plans and will publish information about the latest set of supported ECLIPSE releases on this page.

Featured:

ECLIPSE Release Support

Code
Name
Released Version Our Update Site(s) Notes
Mars 24 June 2015 4.5
Luna 25 June 2014 4.4 Juno Certified on Luna
Kepler 26 June 2013 4.3 Juno Certified on Kepler
Juno 27 June 2012 3.8 and 4.2 Juno Current. This is the current level for NSDEE.
Indigo 22 June 2011 3.7 Indigo, Helios Stable
(bug fixes only). This will be deprecated with the Mars release.
Helios 23 June 2010 3.6 Helios Stable
(bug fixes only). This will be deprecated with the Mars release.
Galileo 24 June 2009 3.5 deprecated
Ganymede 25 June 2008 3.4 deprecated
Europa 29 June 2007 3.3 deprecated
Callisto 30 June 2006 3.2 deprecated
Unnamed 28 June 2005 3.1 deprecated
Unnamed 21 June 2004 3.0 deprecated

Update Site Plans

Update
Site Name
Plans/Notes JDK
Build
Minimum
JRE
Kepler / Luna We have not yet established plans for separate update sites specific to either Kepler or Luna. This will depend on compatibility testing results to be published on our website. 1.7 1.7
Juno This update site will replace the Indigo and Helios update sites for releases of Juno, Kepler, and Luna. We will be commissioning this update site in the next few weeks. 1.7 1.6
Indigo This update site will replace the Helios update site as of the Luna Release as the minimum support/bug-fix level. We expect this site to support ECLIPSE installations through Kepler, except for plug-ins requiring Juno-specific capabilities. Indigo plug-ins are built with JDK 1.6 and have a minimum compatibility level of JRE 1.6. 1.6 1.6
Helios Stable. Only bug fixes will be made to this site effective January 2014. Once Luna is released and support for Helios is dropped by the Eclipse Foundation, this update site will be deprecated. 1.6 1.6
Ganymede The Ganymede Update Site was not migrated to the new Nexbridge website as of November 2013. 1.5 1.5
Older Older versions of update sites dating back to 2004 are no longer unavailable. 1.4.2 1.4.2

Leave a Reply